ScalaIDE 3.0.3 gives error with scala 2.9.x

I am using ScalaIDE version 3.0.3-20140327-1716-Typesafe and I want to use Scala 2.9.x in my project.

I have configured a SBT project which use Scala 2.9.3 and created an Eclipse project :

$ sbt eclipse

After I imported it into Eclipse, I see following error:

The version of scala library found in the build path is incompatible with the one provided by scala IDE: 2.9.3. Expected: 2.10.4. Please replace the scala library with the scala container or a compatible scala library jar.

I then added scala-library 2.9.3 to the dependencies, still I get the same error:

$ cat build.sbt
name := "sample-project"

scalaVersion :="2.9.3"

version :="1.0"

libraryDependencies += "org.scala-lang" % "scala-library" % "2.9.3"

If I add Scala Nature from within Eclipse ( ScalaIDE ) then I get a different error:

More than one scala library found in the build path (/home/tuxdna/.ivy2/cache/org.scala-lang/scala-library/jars/scala-library-2.9.3.jar, /home/tuxdna/software/scala-ide-3.0.3/configuration/org.eclipse.osgi/bundles/290/1/.cp/lib/scala-library.jar).At least one has an incompatible version. Please update the project build path so it contains only compatible scala libraries.

How can I avoid these errors?

EDIT:

Comments 9

发表评论

电子邮件地址不会被公开。 必填项已用*标注